Environment
Novell GroupWise 8
Situation
The error "Execute unknown rulexxx (username)" is appearing sporadically in the PO (post office) log. In addition, some messages are not being filtered as expected, but all messages are being delivered.
Resolution
Cause:
A rule is trying to assign an incoming email message to a category, but the category has been deleted. The message is received but cannot be assigned to the category because it no longer exists.
Corrective Steps:
Either delete the rule that references the non-existent category, or recreate the category.
A rule is trying to assign an incoming email message to a category, but the category has been deleted. The message is received but cannot be assigned to the category because it no longer exists.
Corrective Steps:
Either delete the rule that references the non-existent category, or recreate the category.
Additional Information
This behavior can be duplicated with the following steps:
- As user A, create a category called "test".
- Create a rule to assign all emails from user B to category "test".
- Delete category "test".
- As user B, send an email message to user A.
- The email will arrive successfully but the post office log will show the "Execute unknown rule" error.