Return receipts not being received

  • 7009426
  • 23-Sep-2011
  • 26-Apr-2012

Environment

Novell GroupWise 8
Novell GroupWise 7

Situation

Users send messages to another internet domain and specify under Send Options / Status Tracking that a return receipt email notification is desired when the message is opened by the recipient. When the message is opened, no receipt notification is sent.

Resolution

Cause:
At least one mail server does not support the DSN (Delivery Status Notification) protocol. Each SMTP mail server that handles the message must support this protocol. For example, if the GroupWise system uses MX servers or relay servers, and one of these servers does not support the DSN protocol, the return receipt will not be sent. The reason for this is that each SMTP server must pass along the DSN flag. If the chain is broken, the receiver's server will not get the flag and will not send a return receipt.

This can be verified by these steps. For each server that will be handling the message:
  1. Connect to the server using telnet:
    telnet <server-name> 25
    Trying 192.168.20.16...
    Connected to 192.168.20.16.
    Escape character is '^]'.
    220 <server-name> Ready
  2. Send the extended hello command:
    ehlo
    250-<server-name>
    250-AUTH LOGIN
    250-8BITMIME
    250-SIZE
    250 DSN
  3. The server will return a list of protocols that it supports, each one preceded by "250". Note that in this example, the DSN protocol is supported. If it is missing from any of the servers in the chain, return receipts will not work.
Corrective Steps:
Update the software on any servers that are missing the DSN option to include DSN support. This may involve applying the latest patches or updates to the server, or replacing the software.