Security Vulnerability - GroupWise 8 Internet Agent Yearly RRULE (VCALENDAR) Vulnerability

  • 7009216
  • 19-Aug-2011
  • 26-Apr-2012

Environment

Novell GroupWise 8
Novell GroupWise 8 Internet Agent
GroupWise 8.0x up to (and including) 8.02HP2

Situation

The GroupWise Internet Agent (GWIA) has a vulnerability in the way that it parses certain yearly calendar recurrence (RRULE) variables within a received VCALENDAR message.  The vulnerability could could potentially allow an unauthenticated remote attacker to execute arbitrary code on vulnerable installations of GWIA.
 
This vulnerability was discovered and reported by Anonymous working with Verisign's iDefense Labs (http://www.idefense.com), V-t0ml0ufzg6, V-1idu9rzv8d
 
CVE-2011-2663

Resolution

To resolve this issue, apply GroupWise 8.0 Hot Patch 3 (HP3) or later.
 
Previous versions of GroupWise are likely also vulnerable but are no longer supported. Customers on earlier versions of GroupWise should, at a minimum, upgrade their GWIAs and associated Domains to version 8.02HP3 in order to secure their system.

Status

Security Alert

Bug Number

705917

Feedback service temporarily unavailable. For content questions or problems, please contact Support.