Environment
Novell ZENworks 11 Configuration Management Support Pack 1 - ZCM 11
SP1 Patch Management
Novell ZENworks 11 Patch Management Support Pack 1 - ZPM 11 SP1 Patch Management
Novell ZENworks 11 Patch Management Support Pack 1 - ZPM 11 SP1 Patch Management
Situation
Upgraded to ZCM 11.1
ERROR: "Analyze failed to launch.{}"
ERROR: "BundleManager Analyze failed to launch."
Discover Applicable Updates runs but does not discover applicable patches
ERROR: "Analyze failed to launch.{}"
ERROR: "BundleManager Analyze failed to launch."
Discover Applicable Updates runs but does not discover applicable patches
Resolution
- Add any file to the agent directories on the Patch Management
server - there may be Windows and Linux directories, x86 and x64
directories, depending on the mix of devices in the zone - add a "dummy" file (it does not matter what it is called, or what it contains) to all of the directories shown below that exist on the server
Linux:
/opt/novell/zenworks/zpm/agents/windows/x86
/opt/novell/zenworks/zpm/agents/windows/x64
/opt/novell/zenworks/zpm/agents/linux/x86
/opt/novell/zenworks/zpm/agents/linux/x64
Windows:
%ZENWORKS_HOME%\zpm\agents\windows\x86
%ZENWORKS_HOME%\zpm\agents\windows\x64
%ZENWORKS_HOME%\zpm\agents\linux\x86
%ZENWORKS_HOME%\zpm\agents\linux\x64 - Run an "update now" (ZCC Configuration > Patch Management > Subscription Service Information)
- Remove the files added in step 1
- Run an "update now" (ZCC Configuration > Patch Management > Subscription Service
Information). This last step avoids the "dummy" files
created in step 1 from being delivered to the managed
devices.
Cause
Whenever an "update now" takes place (manually or on a schedule),
part of the process rebuilds the DAU (Discover Applicable Updates)
bundles, and if there has been any change to the files such asanalyze.exe, they
are incorporated into the DAU and delivered to the managed device
along with the rest of the DAU (this allows the files to be
automatically updated without a separate patch needing to be
applied to the server). Usually during the first "update now" after
the upgrade to 11.1, the files such as analyze.exe would have been
delivered to the managed devices, however in this case, the Patch
Management service was reset for an unrelated reason, and Patch
Management did not "realize" that the files had not been delivered.