Error: "This page requires that Identity Manager Version: 3.0.1 or newer be installed on all associated servers."

  • 7008807
  • 14-Jun-2011
  • 26-Apr-2012

Environment

Novell Identity Manager 4.0
Novell Identity Manager iManager Plug-ins

Situation

While using iManager to access the available policysets for an Identity Manager (IDM) driver configuration the following error shows up:

This page requires that Identity Manager Version:  3.0.1 or newer be installed on all associated servers.

A later error is also displayed:

In m_followBreadCrumb(), could not find the breadcrumb.

The IDM servers involved are running IDM 4.0.1.  The IDM plugins in iManager are for IDM 4.0 with dates of 2010-10-08.

Resolution

The error message presented is incorrect in the version requirement for the IDM engine side, but means that newer plugins are required to support IDM 4.0.1.  Upgrading to the IDM 4.0.1 plugins and restarting iManager/Tomcat as required resolves the error message.

IDM's Designer is also available the entire time for driver configuration administration.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.