"zman isn" does not work for device folder

  • 7008636
  • 24-May-2011
  • 27-Apr-2012

Environment

Novell ZENworks 10 Configuration Management Zman
Novell ZENworks 11 Configuration Management Zman
Novell ZENworks 11 Configuration Management Support Pack 1 - ZCM 11 SP1 Zman

Situation

Using "zman isn" to initiate an inventory scan on all devices in a folder, e.g.
zman isn "workstations/head office/floor13"

zman reports There are no devices to assign the quick task.

If a single device is specified, e.g.,
zman isn "workstations/head office/floor13/dellXP27"
then the command works as expected

Resolution

This is fixed in version 11.2 - see KB 7010044 "ZENworks Configuration Management 11.2 - update information and list of fixes" which can be found at https://www.novell.com/support

Additional Information

extract from zman.log, set at debug level (see KB 3418069 How to enable debug logging for ZENworks 10 and 11 Configuration Management for details of enabling debug-level zman logging
[DEBUG] [5/24/11 9:17:59 AM] [] [ZMan] [] [Time taken for logger initialisation:334 ms] [] []
[DEBUG] [5/24/11 9:17:59 AM] [] [ZMan] [] [Command: isn workstations/VMware test devices --port=453 --TerminalDevice=/dev/pts/2 --ScreenDimension=24 80 ] [] []
[DEBUG] [5/24/11 9:17:59 AM] [] [ZMan] [] [] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [JSAP File is inventory-scan-now.jsap] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [Time taken for Parsing:276 ms] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [JSAP File is inventory-scan-now.jsap] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [Time taken for credential retrieval:250] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [Class:com.novell.zenworks.zman.commands.InventoryHandler, Method:scanNow] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [Command is run by the administrator: administrator] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [Checking if we need to cache licenses] [] []
[DEBUG] [5/24/11 9:18:00 AM] [] [ZMan] [] [Should recache: false] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [DatamodelVersion] [] [Read datamodel version: 11.0.0] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [Inventory] [] [Loader performance properties file does not exists in : /etc/opt/novell/zenworks/loaderPerf.properties] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [Zman] [] [DeviceUserHandler.getDevicesinFolder()::Getting devices in the folder /Devices/Workstations/VMware test devices] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [Zman] [] [DeviceUserHandler.createQuickTask()::Some devices already added. Not adding all in device folder /Devices/Workstations/VMware test devices--e92063ea962a966926be69fe780691da] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [ZMan] [] [There are no devices to assign the quick task.] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [ZMan] [] [There are no devices to assign the quicktask Inventory Scan Now] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [ZMan] [] [
] [] []
[DEBUG] [5/24/11 9:18:18 AM] [] [ZMan] [] [Command completed in 19050 ms] [] []

Feedback service temporarily unavailable. For content questions or problems, please contact Support.