Application password appears as a blank field in SLManager

  • 7008304
  • 06-Apr-2011
  • 26-Apr-2012

Environment

Novell SecureLogin
NSL7.0.1
slmanager
eDirectory environment

Situation

Unable to use SLManger to verify existence of a user-defined password
Application password shows as a blank field in SLManager
SLManager shows that a user name is present for an application, but the password field shows as a blank field.
SLManager shows passwords masked with asterksks (**) if entered  by administrator, but blank if entered by user.

Resolution

This is working as designed.  SLManager masks admin-entered passwords with  a  series of asterisks (**), but does not show user-entered passwords at all.

Expected view of password field in slmanager after administrator sets the password:


Expected view of password field in slmanager after user sets the password:


Workaround:
Use iManager if it is necessary to verify that a user-defined password is present.

Additional Information

The different SecureLogin management utilities give different views of the password field. 
If an administrator changes / enters an application password, the password shows masked with a series of asterisks (**) in all eDirectory utilities – SLManager, iManager, and on the workstation in "Manage Logins."   However, if the user changes / enters an application password, the password shows as a blank field in SLManager as noted above, but shows masked with asterisks in iManager, and on the workstation in "Manage Logins,".

Feedback service temporarily unavailable. For content questions or problems, please contact Support.