Unable to delete/move e-mails in Outlook WebAccess (OWA)

  • 7008214
  • 28-Mar-2011
  • 26-Apr-2012

Environment

Novell Access Manager 3.1
Novell Access Manager 3.1 Support Pack 2 IR3a applied
Microsoft Outlook WebAccess 2003

Situation

Access Manager Linux Access Gateway (LAG) setup to protected a Microsoft Outlook WebAccess (OWA) 2003 application server. The published DNS name of the proxy service was setup to be the same as the back end Web server hostname. The proxy service has SSL enabled but the back end server is running over HTTP. Users can access the protected resource, get redirected to authenticate successfully and single sign on to the OWA server.

Users trying to delete or move emails from their mailboxes in this environent fail however. The browser displays a 502 Bad Gateway error. The HTTP logs from the browser confirm that the LAG sends back a 502 response to the browser with each DELETE or MOVE operation.

Resolution

Make sure that the OWA configuration does NOT send the "front-end-https=on" HTTP header to the back end OWA server.

The OWA proxy service is configured for SSL (HTTPS) from the Access Gateway to the client and but HTTP from the Access Gateway to the OWA server.  The enabling of the Front-End-Https header does not work on setups where there is no SSL enabled on the OWA server (see http://technet.microsoft.com/en-us/library/aa997519(EXCHG.65).aspx for more details on this customer front-end-https header.

Make sure to follow the instructions described for Outlook Web Access integration in the Access Manager 3.1 documentation at https://www.novell.com/documentation/novellaccessmanager31/accessgatewayhelp/data/bmbzkrn.html#bl1fyp0 .

Feedback service temporarily unavailable. For content questions or problems, please contact Support.