LPR print jobs appear to be stuck in the job queues

  • 7007785
  • 04-Feb-2011
  • 26-Apr-2012

Environment

Novell iPrint for Linux
Novell Open Enterprise Server 2 (OES 2) Linux Support Pack 2

Situation

Printing through LPR does not work and the job appears to be stuck in the job queue.
 
Forwarding jobs over LPR does not work when logged in with the Novell Client for Windows.

Resolution

A fix for this issue is available and is awaiting release through the Open Enterprise Server update channel. If the fix is needed before that date, please email patchfeedback@novell.com with the subject "Fix Request for Stuck Jobs using LPR".

Status

Reported to Engineering

Additional Information

Cause:
As per RFC1179, the max user name length allowed using LPR is 31 characters.  Therefore when logged into the Novell Client for Linux and the user name and context is longer than 31 characters the print job will fail.