Bad bundle causes loss of all bundle assignments

  • 7007357
  • 10-Dec-2010
  • 27-Apr-2012

Environment

Novell ZENworks 10 Configuration Management

Situation

Migrated bundle causes heap error which marks the bundle service bad and loss of bundle assignments.
 
ERROR (from zmd-messages.log):
 
[DEBUG] [12/09/2010 16:10:04.552] [3552] [ZenworksWindowsService] [43] [] [ConnectMan] [] [Marking IP Location https://server/zenworks-bundleservice/ : Bad] [] []
 [DEBUG] [12/09/2010 16:10:04.552] [3552] [ZenworksWindowsService] [43] [] [ConnectMan] [] [Unknown Exception] [] []
 [DEBUG] [12/09/2010 16:10:04.552] [3552] [ZenworksWindowsService] [43] [] [ConnectMan] [] [Java heap space] [] []
 [DEBUG] [12/09/2010 16:10:04.552] [3552] [ZenworksWindowsService] [43] [] [ConnectMan] [] [  System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   bij System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object() parameters)
   bij Novell.Zenworks.AppModule.Schema.ApplicationService.getAppDetails(GetAppDetailsRequest GetAppDetailsRequest)
   bij Novell.Zenworks.AppModule.WebAppService.GetAppDetails(GetAppDetailsRequest request)] [] []

Resolution

In one case, the problem bundle was too large (too many actions).  The solution is to re-migrate the application as MSI instead of individual actions.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.