Login via Novell Credential Provider does not run login scripts

  • 7007104
  • 26-Oct-2010
  • 02-Feb-2016

Environment

Novell Client 2 SP1-SP4 for Windows Vista
Novell Client 2 SP1-SP4 for Windows Server 2008
Novell Client 2 SP1-SP4 for Windows 7
Novell Client 2 SP1-SP4 for Windows Server 2008 R2
iPrint Client 6.02 For Windows

Situation

Login script does not execute
Drive mappings from login script do not work
User login script does not process

Resolution

Ensure that the "Adobe Drive CS4 Network" Provider is moved to the bottom of the Provider Order.

To modify the provider order:

1. Open the "Network and Sharing Center" control panel view.  To reach this view, click on the Windows network status icon in the Windows task bar notification area and select the "Open Network and Sharing Center" link.  Or right-click on the "Network" item on the desktop or in the Start menu and select "Properties".  Or open the full Control Panel and in the "Network and Internet" category and select "View network status and tasks".
 
2. Once in the "Network and Sharing Center", now select the link on the left-hand side named "Change adapter settings".  This will take you to the "Network Connections" view.
 
3. In the "Network Connections" view, enable the menu by pressing the ALT key.  This will reveal the menu containing "File", "Edit", "View", "Tools", etc.
 
4. From the "Advanced" menu select "Advanced Settings".  On the "Advanced Settings" dialog switch to the "Provider Order" tab
 
5. In the "Provider Order" tab highlight the item "Adobe Drive CS4 Network", and then use the down arrow button to move that item to the bottom of the network provider order list.
 
6. Press OK on the "Advanced Settings" dialog to save your changes.
 
Reportedly, this problem does not occur with the Adobe Drive CS5 / 2.0 product, so upgrading Adobe Drive may also be a solution.

Cause

The problem is caused by the Adobe Drive CS4 registering itself as a network provider with Windows ahead of the Novell Client.

Additional Information

This required change can be applied by using a ZCM (ZENworks Configuration Management) policy.
 
First, detect the network provider string in the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ProviderOrder
and
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder\ProviderOrder

Then, if the order is not set correctly, set it such that the order ends with AdobeDriveCS4_NP.

For example, if the provider order is set to

AdobeDriveCS4_NP,NCFSD,LCredMgr,LanmanWorkstation,RDPNP,webclient
change it to
NCFSD,LCredMgr,LanmanWorkstation,RDPNP,webclient,AdobeDriveCS4_NP


This issue was also reported after installing the iPrint Client v6.02.  The issue is under investigation, however the solution is the same as detailed in the Resolution section above.