iPrint CLIENT_ERROR 0x400 when attempting to manage driver associations

  • 7007014
  • 07-Oct-2010
  • 08-Nov-2012

Environment

Novell iPrint for Linux

Situation

The following error is returned when attempting to change the driver association to a printer agent:

Request (CLIENT_ERROR) - bad status code (0x400)
IPP Error: 0x400

Resolution

The fix is available in the Channel. Once that update is applied, follow these steps:

Select the new profile repair option:
Within a browser, go to this address:
https://<IPorDNSofPrintManagerServer>/PsmStatus/Debug
When prompted for credentials, provide the eDirectory admin without context or dots.
Click the "Repair Profile Associations" link.
This link is visible only when the 13OCT2010 novell-iprint-server RPM or later is applied.

Go to iManager to verify that the problem is gone.

Additional Information

Cause:
This problem is introduced when the following conditions are present:
  • iPrint printers are created using the iprntman tool while novell-iprint-server dated August 2010 or earlier is installed.
    • iPrint printers are commonly created using iprntman in disaster recovery situations and in iPrint migrations from NetWare to Linux.
  • The imported printers have 2 or more profiles associated