Environment
Novell ZENworks 10 Configuration Management with Support Pack 3 -
10.3
Situation
Numerous Device messages in ZCC with the error "Could not find a results file for
remote management policy".
Resolution
Exclude the %zenworks_home%\bin\handlers\ directory from the AV scan. This is also addressed in ZCM 11.2 as we changed the RMEnf.exe to a RMEnf.dll. Circumventing the situation altogether.
Cause
We were
seeing this issue only in case of "exe" policy handlers. The AV was terminating our policy handlers/blocking our policy handlers
from running. Because of this in ZCM 11.2 we made most of the policy handlers to
"dlls". In this case it was the RMEnf.exe being terminated.
Additional Information
Excerpt from the zmd-messages.log, the problem appears to be
related to the remote management policy. The file "remote_management_policy-999Output.xml"
is being deleted and then referenced by another process. The
error reoccurs at random times and on random devices registered to
the zone.
Could not find a results file for remote management policy. Message: Could not find file
'C:\WINDOWS\TEMP\2d548df8-45eb-48b4-b079-17bcb353cb38\-remote_management_policy-999Output.xml'..
Missing file:
C:\WINDOWS\TEMP\2d548df8-45eb-48b4-b079-17bcb353cb38\-remote_management_policy-999Output.xml, however the action is set to continue on failure.
Could not find a results file for remote management policy. Message: Could not find file
'C:\WINDOWS\TEMP\2d548df8-45eb-48b4-b079-17bcb353cb38\-remote_management_policy-999Output.xml'..
Missing file:
C:\WINDOWS\TEMP\2d548df8-45eb-48b4-b079-17bcb353cb38\-remote_management_policy-999Output.xml, however the action is set to continue on failure.