Questions and answers to iManager 2.5 plugins.

  • 7006123
  • 25-May-2010
  • 14-Jan-2014

Environment

Novell NetWare 6.5 SP2
Novell eDirectory 8.7.3 for NetWare 6.5
Novell iManager 2.5

Situation

Questions and answers to iManager 2.5 plugins.

Resolution

Why do I have a message saying "Tasks and Roles are unavailable"?
This can be caused by many issues.  The more common ones are listed below.

1. RBS not setup.  This would be indicated by the following tasks showing a reason of Task Requires prior version of iManager:
Create Dynamic Group, Create Extended Object, Delete Dynamic Group and Modify Dynamic Group.
To resolve this click on Configure iManager (helpdesk guy) - Role Based Services - RBS Configuration.  Click on the Configure iManager link below the yellow icon and follow the prompts.

2. Policy assignments and Set Universal Password say that the schema extensions have not been applied:
Password Management\Forgotten Password functionality is not installed by default.  This error would normally indicate that the older Forgotten Password plugins have been installed but schema was not extended.  The best way to resolve this is to install the latest plugins which also extend schema automatically.  This can be found at https://download.novell.com.  The file name is pwd_mgmt_2.0.2_win.exe.

3. Virtual Office plugins give an error such as NoClassDefFoundError or give a java error for GadgetConfig. 
VO 1.5 is now configured outside of iManager 2.5 and does not support iManager 2.02.  Therefore, if installing OES on NetWare you should also upgrade VO, if installed, to 1.5 as well using the OES upgrade option.   If you have VO 1.3 installed you must keep an iManager 2.02 server somewhere to administer it.  Unfortunately if the VO plugins were present before upgrading iManager 2.02 to 2.5 and VO from 1.3 to 1.5 the old plugins will still be present albeit non-functional.  These should be uninstalled from iManager.  The administrative link for VO 1.5 is now at https://ipaddress/vo.  To uninstall use the Configure iManager - Modules Installation - Install Modules - select the VO modules and select Uninstall.  Once done also delete them from the sys:tomcat\4\webapps\nps\packages directory.  Then stop and re-start Tomcat.

I get a Java NullPointerException error ( Null Pointer Exception ).

Ensure the version of java on the NetWare box is version 1.4.2 SP3.  If not this can be found on download.novell.com.

Does upgrading iManager from 2.02 to 2.5 upgrade all the plugins as well?

No.  During the upgrade only the core iManager plug ins get upgraded.  The other plug ins will remain at their current level. During the upgrade process the existing plug ins not upgraded are copied to a separate area. At the end of the upgrade these plug ins are then re-installed. This allows for non-upgraded plug ins to still be available after the upgrade as well as any custom content an administrator may have created.


Does this mean if I use TID: NOVL101447 to uninstall and reinstall iManager 2.5 only the core iManager plugins will be installed?

Yes.  In order to restore the rest you have several options:

1. If you have the NetWare OES CD's you can re-install them from these.

2. You can go to https://download.novell.com and pull down the file: oes_plugins_netware.zip. Then install the individual npm's after extracting them.

3. The TID mentions making a copy of the sys:\tomcat\4\webapps\nps directory. If this step was performed you can re-install them from the nps directory backup. This is the preferred solution since you can also re-install custom content as well.

 

How can I determine what plugin on the download site goes with which version of iManager?

This can be determined from the plugin's title. Please refer to the table below:

TITLE:  iManager plugin for iManager 2.x or 2.5                          iManager Version: 2.0.x and 2.5
(
This title provides assurance that the plugin will work with iManager 2.5.)

TITLE: iManager plugin for 2.x                                                  iManager Version: 2.0.x and 2.5
(This title indicates it should work on either version.)

TITLE: iManager plugin for iManager 2.0.x                                 iManager Version: 2.0.x only
(This title indicates it will likely only work with iManager 2.0.x.)

 

How will I know when a newer plugin is available for a particular Novell product?

At this time the best way to do this is to periodically go to https://download.novell.com  or https://dl.netiq.com (depending on the product to be managed) and search under the iManager section of our downloads site for the latest plugins.

.
For other iManager 2.5 issues please consult iManager Basic Troubleshooting

Additional Information

Formerly known as TID# 10097133
Formerly known as TID# NOVL101552

Feedback service temporarily unavailable. For content questions or problems, please contact Support.