TEC+ Adapter no longer works after an upgrade to BSM 4.7

  • 7005898
  • 05-May-2010
  • 26-Jun-2012

Environment

Business Service Manager 4.7
Oracle 8

Situation

When performing an upgrade from BSM 4.5 or 4.6 to BSM 4.7, the TEC+ adapter no longer works and the operational console says "cannot process alarms".
The log file reports an "array out of bounds" error.

Resolution

If running Oracle 8 for the T/EC+ database but not using Oracle for the Managed Objects
Configuration Storage database, save the following drivers provided by Oracle in the
ManagedObjectsInstall/classes/ext directory:
ojdbc14.jar
orai18n.jar
Then, restart the Managed Objects server.

Additional Information

Please see the adapter integration guide for more information.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.