Environment
NetIQ AppManager 7.0.x
NetIQ AppManager 8.0.x
NetIQ AppManager 8.0.x
Situation
Discovery_XenApp fails with Error: Failed to initialize MCPSHostServer PowerShell session
Diagnostic Information:
Error Number: 0x80131501
Description: Not Found
Error Number: 0x80131501
Description: Not Found
Resolution
To resolve this issue please do the following:
-
Open task manager.
-
Find and end the MCPSHostServer.exe process if it exists.
-
Restart the NetIQ Client Resource monitor and Client Communication Manager.
-
Run Discovery_NT against the machine.
-
Create a new job on the affected agent, using the Powershell_RunCommand Knowledge Script.
-
Use the following command in the KS parameters to test if powershell is working properly via the KS.
[System.Net.Dns]::GetHostName()
If this works correctly, then re-attempt the discovery for XenApp. If discovery is still unsuccessful please contact NetIQ Technical Support.
Cause
The MCPSHostServer.exe process may be hung or the NetIQ AppManager Agent services may be unable to communicate with the MCPSHostServer.exe process.