Agents show online in the console, however jobs are in stuck in pending start

  • 7005793
  • 30-Apr-2012
  • 30-Apr-2012

Environment

NetIQ AppManager 7.0.x
NetIQ AppManager 8.0.x

Situation

The following error messages are seen in the mctrace.log on the affected agents:
1332800040 [3640] commcenter-pollMSThreadMain: start pollingms thread
1332800040 [3640] mcGetMaintStatusFromMS : maintenance status info request to ms <10.255.255.25>
1332800040 [3640] mcGetMaintStatusFromMS : failed to get adhoc maintenance status from ms <10.255.255.25>, rc=87

Resolution

The MTU size of the packets will need to be configured at the firewall based on the standards within the environment. A matching setting on the Windows machine will also need to be employed. Information on Changing the default maximum MTU size can be found in the following Microsoft Knowledge Base Article. http://support.microsoft.com/kb/826159

Cause

RPC error code 87 equates to 'parameter is incorrect'. This indicates there is an issue with RPC. In this case the firewall seperating the agents from the NetIQ Management Server had been recently reconfigured. While the agent ports 9998 and 9999 are properly defined within the firewall the MTU size restriction at the firewall had been changed withouth changing MTU size on the operating system.