Virtualized ZCM server on VMware ESX becomes unresponsive for undetermined amount of time

  • 7005382
  • 23-Feb-2010
  • 28-Apr-2020

Environment

ZENworks Configuration Management 2017
ZENworks Configuration Management 2020

Situation

ZCM server becomes unresponsive for a random period of time.
Unable to access ZCC.
Slow logins on the workstation.

Resolution

To fix this the reserved memory needs to match the allocated memory amount. 
Additionally, if the primary server operating system is capable, try setting Large Memory pages.

Additional Information

Cause:
A VMware guest had reserved memory of 768MB and allocated memory of 4GB, and then when it hit that limit of the reserved memory.
The reason for this requirement is that Java cannot handle the non-contiguous memory segments that result from Dynamic Memory Allocations.
This is detailed in VMware's Java Best Practice Guide.

https://www.vmware.com/content/dam/digitalmarketing/vmware/en/pdf/techpaper/enterprise-java-applications-on-vmware-best-practices-guide.pdf

BP5: Set memory reservation for VM memory needs:

 JVMs running on VMs have an active heap space requirement that must always be present in physical memory. Using the VMware vSphere Client set the reservation equal to the needed VM memory. 

Reservation Memory = VM Memory = guest OS Memory + JVM Memory 

Set this reservation to the active memory being used by the VM for a more efficient use of the amount of memory available. Or, a simpler approach is to set the reservation equal to the total configured memory of the VM.