Device last contact date definition and Full Refresh and Green Light

  • 7005371
  • 20-Feb-2010
  • 11-Jul-2018

Environment

Novell ZENworks 10 Configuration Management with Support Pack 3 - 10.3
Novell ZENworks Configuration Management 11

Situation

How is the device last contact date derived and how do the device details for last contact date relate to the device last contact search?
 
How is this handled differently than last full refresh?

How is this different than the green light on the device object properties?

Resolution

In ZCC Device Details screen, "Last Contact :" is the last time the device successfully contacted the ZENworks server zenworks registration service URL.
 
In this ZCC Device Search:
 
Devices > Advanced search > Create a search with filter for "Device - Last Contact "
 
the results are based on the device's contact of the ZENworks Server registration web service (zenworks-registration) URL.
 
Note these are different services on the backend ZENworks server.  While typically, all services are either up (ZENworks services started) or down (ZENworks services stopped), it is possible in rare cases for a particular service to be unavailable (file corruption in the tomcat webapps directory for example) while others are available.
 
Last Full Refresh:
 
In zmd-messages.log on device, these two lines indicate that the successful status for both the partial refresh and general refresh are being set.

 

 [DEBUG] [06/02/2010 16:18:42.262] [260] [ZenworksWindowsService] [36] [aubmn] [Status Library] [] [SetStatus: sql= insert into zstatus(timestamp, userguid, objectguid, source, objecttype, operationtype, operationstatus, successcount, failurecount, objectversion ) values ( 634110851222622528,'','',1,'U','Device.Refresh','S',32,0,0)] [] [] 

 [DEBUG] [06/02/2010 16:18:42.472] [260] [ZenworksWindowsService] [36] [aubmn] [Status Library] [] [SetStatus: sql= insert into zstatus(timestamp, userguid, objectguid, source, objecttype, operationtype, operationstatus, successcount, failurecount, objectversion ) values ( 634110851224725552,'','',1,'U','Device.RefreshPartiallySuccess','S',61,0,0)] [] []
 
These status events should  update the last contact time and last full refresh time respectively.

 

The times in the database are not updated until the status is rolled up which happens every 30 minutes by default. So it could take up to about 5 minutes  for the last full refresh time to be updated. However, the last contact time is also set when the device registers. This means it will be updated during the refresh and it is not necessary to wait for the status to be rolled up.


The green light on the device object properties means that the agent is running and listening to this quick task request from primary:  http://deviceaddress:7628/RURunning.

 

 

Cause

This TID primarily aims to define the definitions of Last Contact and Last Full Refresh.  Finding the cause of problems with their updating is beyond the scope of this document.

Additional Information

If the last full refresh time never gets updated the problem could be in the roll up of the status.  In zmd-messages.log. Search for "StatusSender" and "Status Sender". If the status sender is not logging any problems then perhaps there could be an issue on the server. Search the services-messages.log and loader-messages.log for "The Device can not be updated with the last full refresh time" or "[status" errors.