NIC driver not loading for VMware W/S or HP DC5800 with imaging for Intel 82566DM GB NIC

  • 7005281
  • 03-Feb-2010
  • 30-Apr-2012

Environment

Novell ZENworks 10 Configuration Management with Support Pack 1 - 10.1 Imaging
Novell ZENworks 10 Configuration Management with Support Pack 2 - 10.2 Imaging
VMware Workstation 6.0.4

Situation

1.  Imaging for HP DC5800 with e1000e NIC:
 
PXE boot process gets error: "no ZENworks repository found"
 
Manual boot process gets error: "license expired error message"
 
NIC driver is not loaded.
 
2.  PXE fails booting up VMware workstation.

ALT-F3 terminal screen gives the following error.

ERROR:

'Trying to activate eth0.'
'eth0 activated'
'tftp error: timeout'


Download of the PXE files times out.

Resolution

 1.  Fixes for ZENworks Imaging:
 
This is fixed in version 10.3.2 - see KB 7007237 "ZENworks Configuration Management 10.3.2 - update information and list of fixes" which can be found at https://www.novell.com/support
 
A fix for this issue is included in ZENworks 11, see KB 7006995 "ZENworks 11 - information and updates" which can be found at https://www.novell.com/support
 
2.  Fix for VMware environment:
 
The only change required to get this working is to modify the %Vmworkstation_image_location%/vm1.vmx file to add the following:

ethernet0.virtualDev = "e1000"

This will make the virtual machine use the Intel virtualized NIC instead of the AMD.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.