AppManager Management Server Hotfix 7005108

  • 7005108
  • 25-Apr-2012
  • 08-Jun-2012

Environment

NetIQ AppManager 7.0.x

Situation

After you apply Hotfix 73283 for the management server, each time the server no longer requires a connection to the QDB, it destroys the connection instead of keeping it for re-use the next time it needs a connection. As a result, the management server creates a new connection each time it needs to connect to the QDB, which causes slow performance. For example, if you configure a job to collect data, the data takes a long time to appear in the Operator Console and the Control Center console. In addition, if you run mspioc.exe to display information about the persistent IOC (PIOC) queue, the results show a continuous increase in the size of the PIOC files.

Resolution

To correct for this issue, the Management Server in this Hotfix has been modified as follows:

When the management server no longer requires an existing connection to the QDB, it returns the connection to a pool of unused connections. The next time it requires a connection, it checks the pool instead of automatically creating a new connection.

Cause

This is a known issue with the NetIQ AppManager 7.0.x Managemetn Server Service contained in Hotfix 73283.

Additional Information

System Requirements

This hotfix has the following system requirements:

  • Hotfix 72040 or later installed on all AppManager repository (QDB) computers
  • Hotfix 72616 installed on all agent computers
  • Hotfix 72840 installed on all Operator Console computers
  • Hotfix 73020 installed on all Control Center console computers

If you have installed the AppManager 7.x Platform Update, you do not need to install Hotfix 72040 separately. This hotfix is included as part of the Platform Update.

For more information about the AppManager 7.x Platform Update, contact Technical Support.

Installing This Hotfix

To install this hotfix, run AM704_MS-HF7005108_Setup.exe on all management servers.

This hotfix creates or appends to the following logs:

  • PATCH.log, which records all events that occur during the installation process.
  • PATCH.err, which the hotfix installer creates if it cannot create PATCH.log.