Resource lost when doing a reply to all

  • 7004907
  • 23-Nov-2009
  • 26-Sep-2019

Environment

Novell GroupWise 8 Support Pack 1
Novell GroupWise 32 bit Client

GroupWise 2012 Support Pack 2
GroupWise 2014

Situation

When performing a reply to all and the original mail contains a resource (TO or CC), this resource is not present anymore on the reply mail.

Resolution

With regard to GroupWise 8, 12 and 14, this was working as designed.  Since then starting with GW14.2 FTF build 120430 or higher a change was made to resolve this issue.  At that time a new resource type was made of "role".  This resource type does not have this issue.

Cause

Working as designed, before a code change was made to resolve the issue.

Additional Information

In earlier versions of GroupWise, we did not have this issue.  But public demand made it necessary to change the functionality, some customers liked the change, some did not.

Original reasons for why this was working as designed at the time of the initial publishing of this document were :

1) Resources are for scheduling and typically there is no one is there to read and deleted the e-mail messages.  This causes a build of disk space for no reason.

2) Reply-to-all is common with appointments but the resource is not part of the conversation group.  User's do not stop and look at their reply-to-all and would never remember to remove the resource.

3) Since resources usually have rules, we had cases where people did not like the auto-reply they got on a reply-to-all to an appointment (we later added rules being able to trigger on item type and changed the default resource rule to trigger only on appointments).