Sync Engine wont start, unable to listen on https://localhost:8123

  • 7004570
  • 19-Apr-2012
  • 10-Dec-2013

Environment

Novell Data Synchronizer Mobility Pack

Situation

  • Sync Engine not starting.
  • Only app-interface logs are updating.
  • Email is not syncing.
  • Having problems with adding users to DataSynchronizer.
  • Error "unable to listen on https://localhost:8123".
  • netstat -patune | grep 8123 shows the port unused and nothing listening on it
  • Config engine log says it's unable to connect to the postgresql database

Resolution

  1. Make sure that /etc/hosts contains the following. If not, please add it.
    127.0.0.1       localhost
  2. Type ifconfig to make sure interface lo is up. If not, please type ifconfig lo up and press Enter
  3. Restart the server

Cause

Loopback did not start after server was restarted last.

Additional Information

Changing the boot process can help reduce timing issues.  If able to start the loopback manually after bootup then there is a timing issue on boot, that is really an OS issue effecting the NIC dirver loading
Try the boot parallel = no option in the /etc/sysconfig/boot file.
Edit the /etc/sysconfig/boot file.
Find the RUN_PARALLEL="yes" line, and change it to "no".
Then save and reboot. If further problems with the loopback not starting are encountered, contact the Operating Systems team at Novell Technical Support for further assistance.