Cannot login as admin after upgrade or enabling LDAP authentication.

  • 7004412
  • 09-Sep-2009
  • 27-Apr-2012

Environment

Products:
Kablink Teaming 2.0
Novell Teaming 2.0
Novell eDirectory
 
Configuration:
Kablink/Novell Teaming is installed and the login page will display.
Teaming has been configured to Authenticate against an LDAP directory (usually eDirectory).

Situation

Symptoms:
When logging into Teaming 2.x as "admin" a "HTTP Status 500" error is displayed along with an exception report.
After upgrading a Teaming 1.x system, that used LDAP authentication, to Teaming 2.x the admin gets an error logging in.
After configuring Teaming 2.x to use LDAP authentication, the admin user gets an error logging in.
 
Changes:
Upgraded Teaming 1.x to 2.x.
Configured Teaming 2.0 to use LDAP authentication.

Resolution

Workaround Steps:
Search the LDAP directory or eDirectory tree for multiple "admin" users.
Rename either the Common Name (CN) or the Unique ID (UID), depending on which is being used by Teaming, so that only one "admin" user appears for Teaming.
 
Corrective Steps:
This problem has been resolved in the 2.1 version of Kablink/Novell Teaming.
 
An FTF patch for Kablink/Novell Teaming 2.0 can be downloaded from Novell Downloads which will fix this problem.
Patch name: "FTF Novell Teaming 2.0 Admin LDAP login fix", click here to download.
Select Teaming + Conferencing for the Product and Teaming 2.0 for the version, then click on Search to find the patch.

Additional Information

Root Cause:
Kablink/Novell Teaming 2.0 when configured to use LDAP authentication will by default check LDAP on every login.  Novell Teaming 2.0 also cannot resolve the login if more than one search result is returned from the LDAP directory for the same userid.
The 2.1 release or the FTF file prevents Teaming 2.0 from doing an LDAP lookup for the admin user.