Port conflict: iManager and Teaming attempt to use the same port: 8080

  • 7003788
  • 07-Jul-2009
  • 27-Apr-2012

Environment

Products:
Novell Teaming 1.0
Novell Teaming 1.0 Support Pack 1
Novell Teaming 1.0 Support Pack 2
Novell Teaming 1.0 Support Pack 3
Novell Teaming 2.0 
 
Configuration:
Novell Teaming is installed.
Novell iManager is installed.

Situation

Symptoms:

If the Tomcat default page

"If you're seeing this page via a web browser, it means you've setup Tomcat successfully. Congratulations!"

 is displayed when expecting to see the initial Teaming page.

 

Also the Catalina.out shows:

Jun 13, 2008 2:24:56 PM org.apache.coyote.http11.Http11BaseProtocol init

SEVERE: Error initializing endpoint

java.net.BindException: Address already in use:8080

Resolution

If both iManager and Teaming are needed on the same server, it is possible to change the ports:

To change the Teaming ports:

/opt/icecore/liferay-portal-tomcat-5.5-jdk5-4.3.0/bin/icecore stop

Run install and select reconfigure, then select advanced and enter different ports.

/opt/icecore/liferay-portal-tomcat-5.5-jdk5-4.3.0/bin/icecore start

To change the iManager ports:

/etc/init.d/novell-tomcat5 stop

Change the ports in the /var/opt/novell/tomcat5/conf/server.xml file.

/etc/init.d/novell-tomcat5 start

Additional Information

Root Cause:
iManager installation defaults to port 8080.   The iManagers tomcat instance captures port 8080 before the Teaming instance of tomcat loads