Third-Party Imaging fails on Dell Optiplex 980

  • 7003404
  • 08-Apr-2012
  • 30-Apr-2012

Environment

Novell ZENworks 11 Configuration Management Support Pack 2 - ZCM 11 SP2 Imaging

Situation

When trying to perform imaging operations using ZenworksTodo the app shows "could not connect to server"

Resolution

  1. Download the latest WINPE drivers CAB file e.g., Dell-WinPE-Drivers-A06.CAB from the Dell Support site.
  2. Extract the CAB file to a folder, e.g., "Optiplex 980 Drivers".
  3. Copy the winpe.wim file under the WAIK installation e.g., "C:\Program Files\Windows AIK\Tools\PETools\x86" to C:\winpe_dell
  4. Execute the following commands on the WAIK console (note the location in the third command is the location from step 2).
    DISM /Cleanup-Wim
    DISM /Mount-Wim /WimFile:C:\winpe_dell\winpe.wim /index:1 /MountDir:C:\winpe_dell\mount
    DISM /image:C:\WinPE_dell\mount /add-driver /driver:"C:\Users\administrator\Desktop\Optiplex 980 Drivers" /recurse /forceunsigned
    DISM /Unmount-Wim /MountDir:C:\winpe_dell\mount /Commit
  5. Upload the modified winpe.wim through ZCC from Configuration > Device Management > Preboot Services > Third Party Imaging Settings

Cause

winpe does not contain the necessary drivers