Personal Address Book (PAB) is not syncing/downloading to the device or mobility

  • 7003326
  • 06-Apr-2012
  • 10-Dec-2013

Environment

Novell GroupWise 12
Novell GroupWise 8.0.2 HP3
Novell Data Synchronizer Mobility Pack 1.2.1

Situation

Personal Address Books (PABs) are not syncing to devices
Some PABs are syncing to devices, while others are not.
PABs taking a long time to download.

Resolution

Update to 1.2.2 or build 794 for improved PAB syncing reliability.  1.2.2 allows Datasync to skip over bad contacts and download the remaining contacts in order to get majority of the PAB sync'd or downloaded.

Cause

In builds prior to 1.2.2 or build 794, one bad/corrupted contact could prevent the entire PAB from syncing down to Mobility, thus preventing it from reaching the phone.

Additional Information

With 1.2.2, since bad contacts are skipped, it's possible that some contacts will not make it to the device.  This can be worked around by exporting and importing the PAB back into GroupWise, deleting the bad contact and readding it, or possible GWChecks using content fixes or pabonly and pabfix misc options.  Additional fixes should be available in 1.2.3, when it's released.