No vulnerabilities found on device Vulnerability tab

  • 7003101
  • 24-Apr-2009
  • 27-Apr-2012

Environment

Novell ZENworks 10 Configuration Management with Support Pack 1 - 10.1

Situation

After running DAU (Discover Applicable Updates) on a device, no vulnerabilities are shown for that device in the device details > Vulnerabilities tab in ZCC.  Error 2 is seen for all packages in debug.log.
 
ERROR (from debug.log)
 
24 April 2009 04:38:54 PM : !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
24 April 2009 04:38:54 PM : Package:
24 April 2009 04:38:54 PM : Adobe Acrobat Reader 6.0.2 update.pls
24 April 2009 04:38:54 PM : Error Occured: 2
24 April 2009 04:38:54 PM : !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Resolution

Ensure that CABARC.EXE and related files exist in %zenworks_home%\zpm directory.
 
If these files are missing or out of date,  uninstall and reinstall the ZENworks agent.   Note:  CABARC is installed as part of novell-zenworks-patch-management-agent-*.msi .  Simply repairing this msi may resolve the situation (msiexec /fa ).

Additional Information

CABARC is the redistributable CAB file extraction tool from Microsoft. It is used to unpack the PLS files so that they can be analyzed on the device.
 
For a list of possible errors found in debug.log for remediate.exe see KB 7001089 https://support.microfocus.com/kb/doc.php?id=7001089

Feedback service temporarily unavailable. For content questions or problems, please contact Support.