Profile and iPrint printer install errors (iPrint ZLIB -1 and others)

  • 7003001
  • 14-Apr-2009
  • 12-Mar-2013

Environment

Novell iPrint for Linux

Situation


Error when attempting to create a printer driver profile:

Error: Create Printer Driver Profile Failure
Error occurred configuring driver.

Error when attempting to install an iPrint printer:

Novell iPrint
Error message: iPrint ZLIB -1 -Unknown error.
Error group: ZLIB

Resolution

Workaround:
Remove the printer driver from the Driver Store and re-upload the printer driver.

Cause

Cause:
The printer driver being installed or driver being configured to a profile is 22 bytes in size.  This is viewed by typing this command at a terminal:

ll  /var/opt/novell/iprint/resdir/driver_windows-nt-5.1_x86-32_en/[manfacturer and model]/ARCHIVES/resource.zip

In the above command, replace the OS directory (driver_windows-nt-5.1_x86-32_en) and (manufacturer and model) directory with the information appropriate to your environment.  The resource.zip will show 22 bytes.   This scenario exists when the driver within the Driver Store is replaced by a different version (usually a newer version) of the same driver.  iManager prompts the administrator that the driver exists and asks if the driver should be replaced.  If the administrator clicks OK, then the driver is placed in the /var/opt/novell/iprint/resdir location as a 22 byte file.  A 22 byte resource.zip, which is unusable and results in the errors documented above.

Status

Reported to Engineering

Additional Information

Steps to duplicate:

1.  Upload the first driver
2.  Create a printer, associate the driver to the printer.
3.  Install the iPrint printer to a workstation
          - this step copies the driver from /var/opt/novell/iprint/resdir to /var/opt/novell/iprint/mod_ipp
4.  Type this command:
ll  /var/opt/novell/iprint/resdir/driver_windows-nt-5.1_x86-32_en/[manfacturer and model]/ARCHIVES/resource.zip
5.  Note the size of the resource.zip file.
6.  Upload the same driver, but a newer version
        - Choose OK to overwrite the existing driver
7.  Repeat steps 4 and 5.
 
Alternative Information:
One customer reported that the above error occurs when using IE8 with WinXP when logged in as a limited user.  In this scenario, you must log on to the workstation as the administrator user to resolve the problem.