Cross-site Scripting Security Vulnerability with GroupWise WebAccess

  • 7002321
  • 07-Jan-2009
  • 27-Apr-2012

Environment

Novell GroupWise 6.5x
Novell GroupWise 7.0
Novell GroupWise 7.01
Novell GroupWise 7.02x
Novell GroupWise 7.03
Novell GroupWise 7.03HP1a
Novell GroupWise GroupWise 8.0 (shipping 8.0 release only)

Situation

Novell GroupWise WebAccess is vulnerable to Cross-site Scripting (XSS) via POST requests, which could result in non-persistent defacement of the target site, or the redirection of confidential information to unauthorized third parties.
 
This vulnerability was discovered and reported by Richard Brain, ProCheckUp, Ltd (http://www.procheckup.com/), CVE-2009-0273

Resolution

To resolve this issue:
For GroupWise 7.x systems, apply GroupWise 7.03 Hot Patch 2 (HP2) or later
For GroupWise 8.0 systems, apply GroupWise 8.0 Hot Patch 1 (HP1) or later
GroupWise 6.5x is End-of-Life.  GroupWise 6.5 systems will need to be upgraded to GroupWise 7.03 HP2 or 8.0 HP1

Status

Security Alert

Feedback service temporarily unavailable. For content questions or problems, please contact Support.