Shutting down Novell iPrint Manager... failed shutting down ipsmd

  • 7002255
  • 26-Dec-2008
  • 26-Apr-2012

Environment

Novell Open Enterprise Server 2 (OES 2)

Situation

When executing rcnovell-ipsmd restart or rcnovell-ipsmd stop, the terminal prompt sits at

Shutting down Novell iPrint Manager...............................

for a few seconds.  Eventually, the process times out and the following is returned

...failed shutting down ipsmd

In spite of the failed shutting down message, ipsmd is stopped. 

Resolution

Reported to engineering.

No negative side effects, other than taking more time than usual to shut down the print manager, exists as a result of this message. 

Cause:
This condition exists when one or more printer agents is LPR enabled. 

Workaround:
If the LPR feature is not being used, remove the LPR option from the printer agent(s).
iManager -> Manage Print Manager -> Printer Agents -> remove the checks in the LPR column. 

Additional Information

Printer Agents are LPR enabled when administrators wish to send print jobs to an iPrint printer hosted on a Novell server from an LPR client.  Common LPR clients are UNIX hosts or a Windows workstation or server.   This implies that the iPrint Client is not being used.  LPR printing occurs over port 515, and not the more common iPrint port of 631.  By LPR enabling a printer agent, the Novell server listens on port 515.  This port is opened by the /opt/novell/iprint/bin/ilprsrvrd daemon.  This daemon runs only when one or more printer agents are LPR enabled.

This LPR feature should not be confused with communication between the Novell server and the physical printer, which by default occurs over the LPR port.  The LPR feature mentioned in this document is referring to the communication between the client and the server (not server and physical printer).