Unable to associate the server with the Driver Set. (Error -714) The operation was not implemented.

  • 7002052
  • 11-Mar-2009
  • 26-Apr-2012

Environment

Novell Identity Manager 3.5.1
Novell Identity Manager 3.6
Novell iManager 2.7
Novell eDirectory 8.8 for Linux

Situation

It is not possible to associate a server with a Driver Set

iManager and dxcmd return the following error:

Error: com.novell.admin.common.exceptions.UniqueSPIException (Error -714) The operation was not implemented.

Resolution

There are several possible causes for the issue:

Issue:
The schema for Identity Manager was not extended properly during the installation.

Fix:
Reinstalling Identity Manager should extend the schema properly.

Issue:
A version prior to the Identity Manager 3.6.1 Metadirectory Server component was installed on a server running a 64-bit version of eDirectory.

Fix:
Support for 64 bit eDirectory has been added to Identity Manager 3.6.1,
Either Identity Manager needs to be upgraded to version 3.6.1 or the Identity Manager Metadirectory Server component has to be installed on a server running a 32-bit version of eDirectory.

Issue:
The Novell Identity Manager Metadirectory Server component wasn't selected during the installation of Identity Manager.

Fix:
This can be verified by running the following command:

rpm -qa | grep novell-DXMLengn

The command above should return the package name and version. If the engine isn't installed, run the Identity Manager installation again and install the "Metadirectory Server" component. The Novell Identity Manager Metadirectory Server component has to installed on every server that will be associated with a Driver Set.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.