SUSE Support

Here When You Need Us

Installation starts in text mode

This document (7001689) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Desktop
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 10
SUSE Linux Enterprise Server 9
openSUSE

Situation

Installation is selected from the initial boot menu and after loading the installation environment only the text based ncurses interface is displayed.

Resolution

This can be due to issues with the automatically selected graphics driver or the graphical settings being used for the installation. A boot parameter can be added to the startup menu that fixes the problem in many cases.

Boot up the installation DVD and when the boot menu is displayed highlight the "Installation" selection but do not press Enter yet.  Instead type in the following text which will be displayed in the "Boot Options" just below the selections:

x11i=fbdev

Now press Enter to start the Installation with this additional parameter.

If this still fails try to pick a lower or different resolution in the boot menu of the DVD.

Cause

The above mentioned boot parameter picks fbdev as the graphics driver for the installation. fbdev is the lowest denominator for graphics drivers, which should always work. The installation setup automatically detects the graphics card and usually uses the correct driver for that. With some cards, especially newer ones, this might not work and this workaround has to be used.

After the installation has finished a different driver can be installed to use a lot more features of the graphics card.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7001689
  • Creation Date: 21-Oct-2008
  • Modified Date:28-Sep-2022
    • SUSE Linux Enterprise Desktop
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.