Error AE11 on GroupWise Messenger agent and failed messenger client login after password change

  • 7001574
  • 09-Oct-2008
  • 26-Apr-2012

Environment

Products:
Novell GroupWise Messenger 2.0
Novell eDirectory 8.7.3.10 for All Platforms
Novell eDirectory 8.7.3.9 for All Platforms

Configuration:
Universal Password (UP) policy assigned to affected user.

Situation

Symptoms:
User is unable to login to GroupWise Messenger client.
Users is able to login to eDirectory using Novell Client32 with NMAS client installed.
ERROR:  Login failed [0xAE11]: <userid> - DDC: Original password is not valid.
ERROR:  Please enter a valid user ID and password.

Changes:
User has recently changed their password.

Resolution

The UP policy has the "Remove the NDS password when setting Universal Password" option set.  Turn this option off and change the passwords of affected users.

Corrective Steps:
  1. Log in to iManager.
  2. Click on the Passwords -> Password Policies task.
  3. Click the Universal Password tab.
  4. Click the Configuration Options header.
  5. Uncheck the "Remove the NDS password when setting Universal Password" checkbox.
  6. Change user's eDirectory password.

Additional Information

Root Cause:
The help file for the "Remove the NDS password when setting Universal Password" states:
"If this option is checked, the NDS password is disabled when the Universal Password is set.  Checking this option causes users to be unable to log in using older methods or utilities that log in directly with the NDS password instead of communicating with NMAS, such as Novell Clients earlier than version 4.9."

The GroupWise Messenger client does not use NMAS for authentication so it fails when the NDS password is disabled by this option.