Error running novell-zenworks-configure

  • 7001542
  • 07-Oct-2008
  • 27-Apr-2012

Environment

Novell ZENworks 10 Configuration Management with Support Pack 1 - 10.1

Situation

With more than one server in the zone, when novell-zenworks-configure is run on a second or subsequent server installed from 10.1 media and the first primary was upgraded to 10.1 from prior version, novell-zenworks-configure may generate error:
 
ERROR: "Unable to determine the product versions being installed "
 

Resolution

Workaround:
 
Copy the "version_compatibility.xml " file from the Common directory of the 10.1.0 install media to a directory Common underneath a temporary path, for example:
 
C:\tmp\Common\version_compatibility.xml
 
Then, create a directory structure as follows:
 
C:\tmp\Common\a\b\c\d
 
Run the novell-zenworks-configure utility with the addition of the following parameter:
 
-DINSTALLER_LAUNCH_DIR="C:\tmp\Common\a\b\c\d"

Status

Reported to Engineering

Feedback service temporarily unavailable. For content questions or problems, please contact Support.