Applying sles 9 sp4 to a ZLM managed device incorrectly installs old versions of rug and rcd

  • 7001510
  • 02-Oct-2008
  • 30-Apr-2012

Environment

Novell ZENworks 7.2 Linux Management - ZLM7.2

Situation

In a sles 9 sp3 managed zlm 7.2 ir2 device, when applying the SP4 bundle group (created when mirroring updates for sles 9)
it will install older versions of rug and rcd (rug-2.4.9-1.16.3 and rcd-2.4.9-1.20.3).

Resolution

This is happening due to a force install attribute in a sles 9 sp4 patch (patch-11461), which is mandatory in standard sles 9 devices.  This patch is not needed in a zlm managed device (which already has an upgraded version of rug and zmd).  In order to overcome this problem this patch must be filtered out when mirroring the updates for sles 9, specifically include the following line in your zlmmirror configuration file:

<ExcludeBundle>patch-11461</ExcludeBundle>

This will stop this patch from ever being mirrored to the zlm server.  If the patch has already been mirrored, you'll just need to delete it from ZCC, and subsequent mirroring will not download that patch (as long as you have the above tag specified in your mirror conf file). 

Status

Reported to Engineering

Feedback service temporarily unavailable. For content questions or problems, please contact Support.