Some large content may not synch to Windows Satellite

  • 7000166
  • 20-Mar-2012
  • 09-Aug-2012

Environment

Novell ZENworks 11 Configuration Management Support Pack 1 - ZCM 11 SP1

Situation

Some large content zc files may become "blocked" causing content to fail to synchronize to Windows satellites.
 
The following may be seen in zmd-messages.log:
 
 [DEBUG] [03/20/2012 17:04:59.460] [2116] [ZenworksWindowsService] [29] [] [CDP: Default] [] [Failed to download content package 4b1a6697f8d4fe8e31ab3f0554177197: Novell.Zenworks.Cache.ZenCachePostponedException: The user postponed the caching operation
This is not an error, but if the content for that guid never completes the synchronize in future CDP replications, this condition may be true.

Resolution

Workaround:  Extend the content satellite configuration Duration setting so that large files will be synchronized in the first try.
 
 

Cause

When a file is being downloaded to the satellite, if the duration of the sync ends prior to the file finishing download, an entry is made in the fileinfo.db on the CDP.  For example:
 
"220","CDP::4b1a6697f8d4fe8e31ab3f0554177197","5ae5c3d8ec8f8d4283de2850180358b3","C:\WINDOWS\TEMP\tmp8BA.tmp","634454717950000000","43962"
 
Ensure if this tmp file exists in the Windows temp directory and whether the next CDP replicate picks up the content. 
 
In some cases, the file is not picked up.  Even after running zac cvc to fix.

Note if content-repo is on another mount, the %TEMP% variable will be used for location to create the checkpoint files.

Additional Information

https://bugzilla.novell.com/show_bug.cgi?id=752358