Cannot always admin/edit or save changes to Distribution List (DL)

  • 7000143
  • 19-Mar-2012
  • 20-Aug-2012

Environment

Novell GroupWise 8 Support Pack 2 Hot Patch 3
Novell GroupWise 2012

Situation

  • Receive the following error message on the client when saving changes to a Distribution list: "An error occurred while saving the item to the address book".
  • Receiving error message: "An error occurred while saving the item to the address book" also seems to trigger a C006 error on the POA verbose logs.
  • Not always able to add or save new users to a Distribution list, from the client.
  • Not always able to add or save comments to a Distribution list, from the client.
  • Comments added to a Distribution list, sometimes get erased or partially erased.

Resolution

Fixes have been checked in for GroupWise 2012 SP1.  At this time, 2012 SP1 is expected to be released in the Summer of 2012.

A good workaround is not possible at this time.  Keep closing and reopening the DL until needed user and/or comments are successfully saved.

Cause

The core of this issue is in System Address Book. The problem is that calling certain attributes modifies all group member records as well as itself--meaning each record including all the group member records get new drns, and the old records are deleted. Also fixed a problem that occurs when adding a new user to a system group, saving that change, and then removing the user without exiting the group details dialog. In that case the remove would remove the user record, not the user's group member record. So it would delete the user from the system. The solution is to look up member records based on their dpu in order to find the new record's drn, also do this when removing or updating member records that are not actually member records.

Additional Information

Steps to duplicate:
  1. Connect to owning domain, create a new Distribution List.
  2. Change Visibility to System before adding recipients and admins.
  3. Add recipients and the admins.
  4. Login to GroupWise as one of the admin users.
  5. Opened up new DL from the NAB.
  6. Add a comment, saved it and close the DL.  Should be able to add at least one comment for now.
  7. Reopen the DL, part of the previously added Comment may have been removed.
  8. Add a user, save with new comment, may get a "An error occurred while saving  the item to the address book" error message.
  9. Close the DL, reopened it, should be able to open the DL correctly with edit rights.
  10. Checked POA log, noticed a C006 error for the user that was trying to edit the DL.


This problem was worse than the originally reported. NOTE that before this was fixed it was possible to delete user's from the system address book.  When removing the user you just added to the DL, Notice that instead of deleting the member record it deleted the user record.