Unable to send mails to any recipients using SMTP Client if there is an invalid recipient in the mail

  • 7000116
  • 18-Apr-2008
  • 27-Apr-2012

Environment

Products:
Novell GroupWise 7
Novell GroupWise Internet Agent (GWIA) 7
Microsoft Outlook
Outlook Express
Configuration:
SMTP Client such as Outlook Express or Novell GroupWise or Microsoft Outlook being used to send mail
Option that the Outgoing Server requires Authentication is selected on the SMTP Client

Situation

Symptoms:
Unable to send mails to all recipients using SMTP Client if there is an invalid recipient in the mail
ERROR: "The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'alsjdfa@nwgw.com'. Subject 'use', Account: '164.99.12.141', Server: '164.99.12.211', Protocol: SMTP, Server Response: '550 No such recipient', Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC79" while using Outlook Express if the mail contains an invalid recipient in the recipient list

Resolution

Reported To Engineering

Workaround Steps:
1. Install a Second GroupWise Internet Agent in the GroupWise System
2. Edit the GWIA.CFG of the GroupWise Internet Agent to which the SMTP Clients connect and add the following switch in the file
/fut-[ipAddressOfNewGWIA]
Eg. /fut-[164.99.12.211]
3. Save the file
4. Restart the GroupWise Internet Agent to which the SMTP Clients connect
This will cause all the undeliverables to be forwarded to the Second GWIA and the Second GWIA will perform a bounce back of the message that is undeliverable

Additional Information

Root Cause:
When GWIA encounters an invalid recipient (userid that does not exist in the GroupWise System), GWIA returns a "550 No such recipient", which by the way is a valid message because that user does not exist in the GroupWise System. However, as soon as the SMTP Client receives a "550 No such recipient", it sends a QUIT command ending the session
Steps to Duplicate:
1. Create a user named "valid" and "admin" in your GroupWise System
2. Configure Outlook Express for IMAP and SMTP using the admin user account
3. Make sure that the option "My server requires authentication" in the Outgoing Mail Server in Tools | Accounts | Account Name | Server | Outgoing Mail Server is selected
4. Now compose a mail with the following recipients in the To field
5. Fill in the subject and body
6. Try to send the mail
7. The mail will not reach any recipients and an error is received immediately as "invalid" is not a valid user in the GroupWise System