Nsure Audit Support for eDirectory 8.8

  • 3912432
  • 10-Oct-2007
  • 11-Jul-2012

Environment

Novell Nsure Audit 1.0.3
Novell eDirectory 8.8
Novell Identity Manager 3

Situation

Nsure Audit Support for eDirectory 8.8

Resolution

Novell Nsure Audit Log Server has been tested against eDirectory 8.8 and will be supported in conjunction with Identity Manager 3.0.

The Nsure Audit eDirectory instrumentation has not been tested against eDirectory 8.8 and will not be supported.

Configuring the Secure Log Server for Windows and NetWare
No change is required for the operating environment to make the Secure Log Server function on a NetWare or Windows server running Novell eDirectory 8.8.

Configuring the Secure Log Server for Linux and Solaris
The LD_LIBRARY_PATH environment variable needs to be updated to include /opt/novell/lib.
There are many ways to do this, including /etc/profile and /etc/profile.local scripts. One recommended way to do this is within the startup script for Nsure Audit.

In /etc/init.d/novell-naudit on Linux, or /etc/init.d/naudit on Solaris, add /opt/novell/lib to the line that starts with LD_LIBRARY_PATH=
For example:

LD_LIBRARY_PATH=/usr/lib:/opt/novell/naudit:/opt/novell/eDirectory/lib:/opt/novell/eDirectory/lib/nds-modules:/opt/novell/lib:$LD_LIBRARY_PATH

After making this change, the secure Log Server will load properly.

It is also possible that the schema extension tool will not load correctly without the LD_LIBRARY_PATH evironment variable being properly exported. Prior to running auditext, type:
export LD_LIBRARY_PATH=/usr/lib:/opt/novell/naudit:/opt/novell/lib:$LD_LIBRARY_PATH


Additional Information

Novell Audit 2.0 will fully support eDirectory instrumentation and the Secure Log Server as installed. No changes to the environment will be necessary, unless eDirectory is installed in a non-default location.

Formerly known as TID# 10099749

Feedback service temporarily unavailable. For content questions or problems, please contact Support.