New Device with appended GUID appearing after server or agent reboot

  • 3796509
  • 19-Nov-2007
  • 27-Apr-2012

Environment

Novell ZENworks 10 Configuration Management

Situation

New device with guid appended is created with each reboot of ZCM server or device. This is particularly problematic if the device is itself the ZCM server.
From ZCC Devices / Servers:
Running ziswin.exe:
Registry setting for HKLM\Software\Novell\Zenworks\PreAgent\Guid is missing.

Resolution

This is fixed in version 10.1 - see KB 7001200 "ZENworks 10 Configuration Management with SP1 (10.1)" which can be found at https://www.novell.com/support
 
In 10.1 deviceguid file is prioritized over zisd data.

Additional Information

From Windows event viewer (Application/Warning/ZENworks):
WARN: [11/11/07 10:02:51 AM] Registration Web Service Novell.Zenworks.Registration.DEVICE_NAME_CHANGED Device name already existed, changed to virtual-w2003-fdfc312b3f7aba4db695088b5b856e02 while attempting to register host: VIRTUAL-W2003
From zmd-messages.log:
[DEBUG] [11/7/2007 2:38:47 PM] [] [ZenCache] [] [GetObject called for DeviceGuid.DontUseGuidDotText] [] []
[DEBUG] [11/7/2007 2:38:49 PM] [] [DeviceGuid] [] [GetDeviceGuid not trying guid.txt] [] []
[DEBUG] [11/7/2007 2:38:49 PM] [] [DeviceGuid] [] [GetGuidFromServerGuidFile returned null.] [] []
[DEBUG] [11/7/2007 2:38:49 PM] [] [DeviceGuid] [] [GetStoredGuid (from ISD) returned null.] [] []
[DEBUG] [11/7/2007 2:38:50 PM] [] [DeviceGuid] [] [Did not find the file deployquid.txt.] [] []
[DEBUG] [11/7/2007 2:38:50 PM] [] [DeviceGuid] [] [GetGuidFromDeployConfig returned null.] [] []
[DEBUG] [11/7/2007 2:38:50 PM] [] [DeviceGuid] [] [Generating a new device guid: ] [] []
[DEBUG] [11/7/2007 2:38:50 PM] [] [DeviceData class] [] [Failed to retrieve device data from ImageSafeData - using local file] [] []

Feedback service temporarily unavailable. For content questions or problems, please contact Support.