Environment
Novell iPrint Client for Windows 4.x
Situation
iPrint printer doesn't install with "unknown installation error
1223".
C:\NDPS\ippErrs.txt shows:
Routine: GetDriverInstallInfo - DrvInstall failed 1223
Error: iPrint Driver Install - Unknown installation error
C:\NDPS\ippErrs.txt shows:
Routine: GetDriverInstallInfo - DrvInstall failed 1223
Error: iPrint Driver Install - Unknown installation error
Resolution
Look at c:\winnt\setupapi.log to see what is missing after trying
to install the printer.
Additional Information
Cause:
One or more files that make up the driver package is missing or not available. Many printer drivers will look to the driver.cab file in this folder for files that are not installed already. Some customers report that the problem occurs on only some machines. Sometimes, two machines will have the same problem of driver packages missing or not being available, but one machine will work because the printer driver is already installed to the workstation.
To view printer drivers that installed to Windows, go to: Start -> Settings -> Printers and Faxes -> File -> Server Properties-> Drivers tab.
Novell has received reports of the following specific scenarios causing the problem:
Scenario 1: stdnames.gpd, ttfsub.gpd and other *.gpd files are missing within the %windir%\driver cache\i386 directory on machines experiencing the problem. Resolution: Copy the *.gpd files from a known good machine to a failing machine.
Scenario 2: The %windir%\driver cache\i386 directory is locked down. Resolution: Unlock the driver cache\i386 directory.
Scenario 3: The %windir%\driver cache\i386 directory is empty. Resolution: Copy the SP1.cab, SP2.cab, and driver.cab files from a known good workstation to the problem workstation.
One or more files that make up the driver package is missing or not available. Many printer drivers will look to the driver.cab file in this folder for files that are not installed already. Some customers report that the problem occurs on only some machines. Sometimes, two machines will have the same problem of driver packages missing or not being available, but one machine will work because the printer driver is already installed to the workstation.
To view printer drivers that installed to Windows, go to: Start -> Settings -> Printers and Faxes -> File -> Server Properties-> Drivers tab.
Novell has received reports of the following specific scenarios causing the problem:
Scenario 1: stdnames.gpd, ttfsub.gpd and other *.gpd files are missing within the %windir%\driver cache\i386 directory on machines experiencing the problem. Resolution: Copy the *.gpd files from a known good machine to a failing machine.
Scenario 2: The %windir%\driver cache\i386 directory is locked down. Resolution: Unlock the driver cache\i386 directory.
Scenario 3: The %windir%\driver cache\i386 directory is empty. Resolution: Copy the SP1.cab, SP2.cab, and driver.cab files from a known good workstation to the problem workstation.