BuildBanner() failed message in Logger screen

  • 3616192
  • 06-Mar-2007
  • 26-Apr-2012

Environment

Novell iPrint for NetWare Novell NetWare 6.5 Support Pack 6

Situation

BuildBanner() failed message appears intermittently in the Logger screen after applying Support Pack 6 to a NetWare server.

Resolution

Reported to engineering.

Cause:
The intent of the BuildBanner() failed message is to inform the administrator that a Printer Agent has been configured to print a legacy banner, but the banner was not printed. The most likely reason for the banner failing to print is because legacy banners are intended to work with PS or PCL generated jobs. If this message appears in the Logger screen, then the print job was most likely submitted in a language other than those two. Feedback from customers has revealed that the message of "BuildBanner() failed" is confusing. Novell is investigating a more meaningful message to report to the administrator.

If/when a new message is coded, it will state that a banner is configured to be printed, but was not successful. The message will also identify the Printer Agent name.

Status

Reported to Engineering

Additional Information

Legacy banners are configured using NWAdmin or by going to iManager -> iPrint -> Manage Printers -> Configuration -> Defaults (Legacy). iPrint also has a Customer Banners feature which can be configured by going to iManager -> iPrint -> Printer Banner Configuration. The Customer Banners feature does not apply to the message described above.