Delays using iPrint User Printers

  • 3611869
  • 20-Aug-2007
  • 26-Apr-2012

Environment

Novell iPrint Client for Windows
Novell iPrint for Linux
Novell iPrint for NetWare

Situation

Delays are seen with iPrint User Printers when:
a. Waiting on the Print Dialog to list the printers when clicking File -> Print in an application.
b. Waiting for the Windows Printers and Faxes list to display the installed printers
c. Printing a job.

Resolution

Apply iPrint client 4.30 or later.

Cause:
In some environments, the name IPP: is attempted to be resolved on the network when iPrint User Printers are installed. All Network Providers installed to the workstation will attempt to resolve that invalid name. Each provider will go through it's timeout period before handing the name resolution effort to the next provider. This can result in long delays, even beyond 2 minutes.

The 4.30 and later versions of the iPrint client changed the way iPrint User Printers are resolved. IPP: will no longer be requested to resolve.

Additional Information

To understand the difference between a User Printer and a Workstation Printer, read TID titled: "What are iPrint user printers?" While User Printers are discouraged with workstations, Terminal Services needs them. If Workstation Printers were used in a Terminal Server environment (which can be done, but is awkward in most TS environments), then a user would see every printer that every user has installed. Depending on the printing needs, the list of printers could be too cumbersome to manage. Installing iPrint user printers causes the user to see only the printers that user had installed.

iPrint user printers' port assignment is stored in the registry at: HKCU\Printers\Connections\,,ipp://[IPorDNSofTheiPrintServer],[PrinterAgentName]\Port.

The data stored in the Port key will look something like: \\ipp://[IPorDNSofTheiPrintServer]/ipp/[PrinterAgentName].

With iPrint clients 4.28 and earlier, storing the printer port in an ipp:// format causes all Network providers configured on the Windows machine to attempt to resolve the ipp URL. Of course, the resolution protocols attempted (NetBIOS, DNS, NDS, SLP, Bindery, SAP, etc) will fail. Each failure must go through a timeout period. Waiting for each protocol to timeout will result in long delays (between 15 seconds and 2 minutes). From an end user perspective, the delays are mostly noticed when:

a. Waiting on the Print Dialog to list the printers when clicking File -> Print in an application.
b. Waiting for the Windows Printers and Faxes list to display the installed printers
c. Printing a job.