Environment
Novell GroupWise 7
Novell GroupWise 6.5
Novell GroupWise 6
Novell GroupWise 5.5
Novell GroupWise Message Transfer Agent
Novell GroupWise Post Office Agent
Situation
Purpose:
The purpose of this technical document is to explain why
messages appear in the problem queues in the GroupWise system and
what can be done with them.
Symptoms:
Files display in the problem queues (directories) of the post
office or domain.
Message files appear in the domain/wpcsout/problem
directory.
Message files appear in the post
office/wpcsout/problem directory.
Resolution
Corrective Steps:
If the messages are in the post office's problem directory, it
may be possible to re-queue them. This is done by simply
moving the files from the post office/wpcsout/problem
directory to the post office/wpcsout/ofs/4
directory. If the messages can be processed (meaning they are
not corrupt) they will be sent. If they cannot due to
corruption, they will reappear in the problem directory.
Note:
If the GroupWise system is configured to mail problem messages
to the GroupWise administrator, check the mailbox of the GroupWise
administrator for messages with problem messages
attached. There may be instructions in these messages for
handling the problem files.
Additional Information
Root Cause:
The two main causes of messages entering the problem queues
are corruption and misconfiguration.
For the domain, files placed in the problem directory have
been damaged in some way that makes them unreadable. This
should happen very rarely. If it is happening regularly,
contact Novell Support for assistance in analyzing the source of
the corruption. There is no way to re-queue these messages
for delivery.
For the post office, it is possible that misconfiguration
could cause messages to be placed in the problem directory.
For example, if a POA was assigned the same IP address as another
POA, the MTA would start sending mail for users on both post
offices to the same POA causing a lot of problem messages for the
users that are not on that post office. If the cause is
misconfiguration it will likely yield a high number of problem
messages all at once. Once the misconfiguration is resolved,
most or all of the problem messages will be able to be sent by
re-queueing them as described in the resolution section of this
TID.
It is also possible that the cause is corruption in which
case the same rules apply as with the domain mentioned above.