Identity Manager 3.5.1 & DXLDAP.NLM Error

  • 3467486
  • 06-Nov-2007
  • 30-Apr-2013

Environment

Novell Identity Manager 3.5

Situation

Questions have come up regarding the dxldap.nlm module. Mainly, what is it and why the description is identical to the one for dxevent.nlm?

The other question is that when a NW 6.5 SP6 server is loading you see the following:
Loading module DXLDAP.NLM
DirXML Event Handler for Novell Directory Services 3.5.1
Version 3.05.10 18 September 2007
Copyright 1999-2007 Novell, Inc. All rights reserved. Patents Pending.
SERVER-5.70-918: Loader cannot find public symbol: NLDAPSetResponseBer for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPGetBerFromHandle for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPSendResult for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPGetContext for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPBerAlloc for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPBerFree for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPBerPrintf for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPBerScanf for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPFree for module DXLDAP.NLM
SERVER-5.70-918: Loader cannot find public symbol: NLDAPIsSecureConnection for module DXLDAP.NLM
Error processing External Records.
Module DXLDAP.NLM NOT loaded
Module DXLDAP.NLM load status UNRESOLVED
The module seems to remain loaded nevertheless.

Resolution

DXLDAP is new for 3.5.1 and handles the IDM LDAP extensions. When the errors occur DXEVENT is attempting to load DXLDAP so that DXLDAP can install the extension descriptions on the LDAP Server object. That load can fail and nothing bad will happen except that the LDAP extensions won't be installed (and if they already are installed, no big deal).

Once the server is up, unload DS followed by load DS will take care of the extension descriptions if they didn't get installed for some reason when 3.5.1 was installed.

Normally those errors do not cause any problems.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.