Updating from eDirectory 8.7.3.8 to eDirectory 8.8.2 causes SLP errors in the messages file

  • 3284718
  • 18-Mar-2008
  • 26-Apr-2012

Environment

eDirectory 8.7.3.8
eDirectory 8.8.2
slpuasa
Open SLP

Situation

After upgrading from eDirectory 8.7.3.8 to eDirectory 8.8.2 the following error is reported over and over in the /var/log/messages file.

"... libslp: slp_open_ipc: could not connect to slpd: Connection refused"

SLP and eDir are still working fine even with these messages.

Resolution

Starting with eDirectory 8.7.3.5 Novell discontinued shipping and supporting the proprietary slpuasa SLP solution in favor of the open source Open SLP solution.

The slpuasa solution was based off of SLP version 1.
Open SLP is based on SLP version 2.
SLP version 1 has limitations not found in SLP version 2.

Because of these facts Novell only recommends, ships, and supports Open SLP.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.