Hard hang during restart or shutdown on systems

  • 3197913
  • 11-Feb-2008
  • 26-Apr-2012

Environment

Novell NetWare 6.5 Support Pack 7
Dell PowerEdge 1950
Dell PowerEdge 2900
Dell PowerEdge 2950
USB devices

Situation

During restart or shutdown of a system that is using USB devices, a hard hang ("blank screen") is experienced.

Resolution

Update the USB drivers to the ones found in the file usb6571.zip. This driver set is also be included in NW65SP8

Additional Information

Root cause

It is the expectation of the BIOS that all USB version 2.0 devices will be handed back first and then USB version 1.x devices. However when NetWare is shutting down it may hand control back to the BIOS of the USB version 1.x devices first. When this occurs it causes the system to hard hang.

The updated versions of the USB drivers ensure that during shutdown of NetWare, the USB hand off from NetWare to the BIOS is done in the expected order of all USB version 2.0 devices first.