ZCM 10 Install hangs

  • 3127543
  • 18-Dec-2007
  • 27-Apr-2012

Environment

Novell ZENworks 10 Configuration Management
Microsoft Windows 2003 Server

Situation

ZENworks 10 Configuration Management installation hangs.
Problems with Java Virtual Machine environment when installing ZCM 10.
Install Anywhere dialog goes to 100% then stops but ZCM 10 installation should continue.
ZCM 10 install debug window shows bind failed errors (enable the debug window by following TID3418069 ) :
"ERROR: transport error 202: bind failed: Address already in use ["transport.c",Lglnit.c",L500]"
"ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)["debuglnit.c",L500]"
"JDWP exit error JVMTI_ERROR_INTERNAL(113): No transports initializedFATAL ERROR in native method: JDWP No transports initialized, jvmtiError=JVMTI_ERROR_INTERNAL(113)"

Resolution

To work around the problem, install ZENworks 10 Configuration Management on a server with no other applications installed on it. In this instance, the machine where ZCM 10 was not able to be installed only had theJava DBfrom Sun and OfficeScan from TrendMicro installed on it, but neither of these applications appear to be the root cause of the ZCM 10 install hang.
For other Java Virtual Machine problems, the following steps can be used as a work around:
  1. On the machine where the ZCM 10 install will be performed, install the Sun JRE 1.50 Update 14 fromhttps://sdlc4d.sun.com/ECom/EComActionServlet;jsessionid=617EB0C1C3F6C43B8A9E665537C8CB6B (JRE 1.50 Update 14 is the default JVM that the ZCM 10 install uses to install to a machine if no prior JVM exists).
  2. Make sure that Java is in the Windows environment variable path.
  3. Run the ZCM 10 installation with the following parameters from a DOS command prompt "setup.exe --no-vm"

Feedback service temporarily unavailable. For content questions or problems, please contact Support.