Environment
Sentinel 5.1.x
Situation
Resolution
Symptom:
Login failure due to timeout.
Possible Cause
(1):
configuration.xml is mis-configured. Check the configuration.xml
for proper IP address/hostname to Sentinel Server (sonic brokerURL,
this is in two places).
Possible Cause
(2):
Communication layer (Sonic) is not running.
To start Sonic
1. (For Unix) Login as user esecadm,
run:
ps ef | grep –i sonic
If there isn't an instance of
Sonic, you can start Sonic by entering
/usr/local/bin/startcontainer.sh
2. (For
Windows), in the Services Window, start eSecurity
Communications.
If you cannot get Sonic
Started, run the following script and restart Sonic.
For Windows, a lock may be
present. Go to %ESEC_HOME%\sentinel\scripts and run:
remove_sonic_lock.bat.
For Solaris, two lock files may
be present. Go to $ESEC_HOME/sentinel/scripts/ and run:
./remove_sonic_lock.sh.
Possible Cause
(3):
Database password is
changed. Use the dbconfig utility to change your password. See the
e-Security Reference Manual – Data Access Service for more
information.
Possible Cause
(4):
(For Windows) DAS_Query may not be connected to Sonic.
1. Start > Programs > e-Security > SonicMQ > SonicMQ 6.1 > Management Console.
2. Set the domain to "esecDomain” and the Connection URL to "tcp://localhost:10012”.
3. Click OK, Management Console should connect to the Sonic broker.
4. Click on the "Manage” tab. In the tree on the left, select Containers > esecContainer > esecBroker > Connections.
5. Click on the Identity column to sort by Identity name. If DAS_Query is connected to Sonic, you’ll see two DAS_Query’s in the list.
If you don’t see DAS_Query in the list, then that means either DAS_Query is not running or it not pointing to the right Sonic broker. Check the configuration.xml file to make sure it’s pointing to the right Sonic Broker. Also check the bottom of the configuration.xml to make sure the DAS_Query process’s"min_instances” property is set to one ("1”). If it’s set to zero, watchdog is will not attempt to start DAS_Query. If the configuration.xml file looks fine, check the DAS_Query log file in $ESEC_HOME/sentinel/bin for errors.
The Sonic Management Console is also available on Linux and Unix platforms. Alternatively it may be easier to use the list_broker_connections script included with Sentinel 6. Run this script with the host and port information of the Sonic server for parameters:
cd $ESEC_HOME/bin
./list_broker_connections.sh sonicServerNameOrIP 10012
The output can be redirected to a file for convenient collection to be reviewed later or sent to a colleague.